Задать вопрос
28 мая, 13:11

Составьте алгоритм и напишите программу для того чтобы выяснить является ли введённое шестизначное число счастливым суперсчастливым или обыкновенным. Шестизначное число называют счастливым если сумма первых трёх его цифр равна сумме трёх последних цифр. Число будет называться суперсчастливым если оно во-первых счастливое а во-вторых сумма первых трёх его чисел равна 11 или 22

+4
Ответы (1)
  1. 28 мая, 14:39
    0
    Var n:longint;

    c1, c2:byte;

    s:boolean;

    begin

    s:=false

    readln (n) ;

    c1: = (n mod 10) + ((n div 10) mod 10) + ((n div 100) mod 10) ;

    c2: = ((n div 1000) mod 10) + ((n div 10000) mod 10) + ((n div 100000) mod 10) ;

    if c1=c2 then s:=true;

    if s and ((c2=11) or (c2=22)) then writeln ('supershastlivoe') else

    if s then writeln ('shaslivoe') else writeln ('prostoe') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте алгоритм и напишите программу для того чтобы выяснить является ли введённое шестизначное число счастливым суперсчастливым или ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Нужно найти счастливое число, счастливым число называется если сумма первых трёх цифр равна сумме последних трёх цифр и эти суммы являются чётными, проверьте на ошибки program swan_1; var y, z, c, d, p, f:integer;
Ответы (1)
Шестизначный билет для проезда в любом транспортном средстве называется "счастливым по-ленинградски", если сумма первых трёх его цифр равна сумме трёх последних его цифр.
Ответы (2)
Дано четырехзначное число. Проверить, является ли оно "счастливым билетом". Примечание: счастливым билетом называется число, в котором: а) при четном количестве цифр в числе сумма цифр его левой половины равна сумме цифр его правой половины;
Ответы (1)
С клавиатуры вводится целое шестизначное число. Необходимо определить, является ли оно "счастливым". ("Счастливыми" называются те числа, у которых сумма перых трёх цифр равна сумме вторых трёх цифр).
Ответы (1)
Ввести шестизначное число с клавиатуры. Проверить, является ли оно счастливым (суммы первых трех цифр равна сумме последних трех)
Ответы (1)