Задать вопрос
14 марта, 16:52

Программирование

Тема: процедуры

Дан массив, содержащий нулевые элементы. Создать массив из номеров этих элементов.

+3
Ответы (1)
  1. 14 марта, 18:46
    0
    Pascal

    const

    n = 15;

    type

    mas = array [1 ... n] of integer;

    var

    m : mas;

    i : integer;

    procedure inic (var a : mas) ;

    var

    i : integer;

    begin

    for i : = 1 to n do

    a[i] : = 0;

    end;

    procedure num (var a : mas) ;

    var

    i : integer;

    begin

    for i : = 1 to n do

    a[i] : = i;

    end;

    procedure w (var a : mas) ;

    var

    i : integer;

    begin

    for i : = 1 to n do writeln (m[i]) ;

    readln () ;

    end;

    begin

    inic (m) ;

    num (m) ;

    w (m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программирование Тема: процедуры Дан массив, содержащий нулевые элементы. Создать массив из номеров этих элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В целочисленной последовательности есть нулевые элементы. Создать массив из номеров этих элементов. То-есть дан массив в которым есть нулевые значения. Например: 20330120 От Вас требуется создать массив из номеров этих нулевых значений.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан массив натуральных чисел. Найти сумму элементов кратных данному К. 2. В целочисленной последовательности есть нулевые элементы. Создать массив из номеров этих элементов. 3. дана последовательность целых чисел а1, а2, ... аn.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)