Задать вопрос
29 августа, 15:40

Составить программу и алгоритм для заполнений массива 3 х3 символом, введенным пользователем, и вывода его на экран

+1
Ответы (1)
  1. 29 августа, 16:22
    0
    Const

    n = 3;

    var

    a : array [1 ... n, 1 ... n] of char;

    i, j : integer;

    b : char;

    begin

    //Считывание массива

    readln (b) ;

    for i : = 1 to n do

    for j : = 1 to n do

    a[i, j] : = b;

    //Вывод массива

    for i : = 1 to n do

    begin

    for j : = 1 to n do

    write (a[i, j],' ') ;

    writeln () ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу и алгоритм для заполнений массива 3 х3 символом, введенным пользователем, и вывода его на экран ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Дан двухмерный массив m*n случайных целых чисел, которые должны генерироваться в диапазоне [-5, 7], где 1 ≤ т ≤ 9, 1 ≤ n ≤ 10.
Ответы (1)
Cоставить алгоритм и программу для: 1) Заполнения лвумерного массива (6x4) произвольными значениями и вывода его на экран! 2) Подсчета произведения элементов по строкам и вывода на экран номеров строк и соответствующих произведений элементов!
Ответы (1)
Задание 1: Составьте программу ввода с клавиатуры массива целых чисел a[1 ... 10] и вывода на экран элементов массива с нечетными значениями. Задание 2:Составьте программу ввода с клавиатуры массива целых чисел a[1 ...
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)