Задать вопрос
25 мая, 10:08

8. Дан целочисленный линейный массив. Вставить в него число 100 после m-го элемента, если этот элемент четный. В противном случае - перед ним.

+4
Ответы (1)
  1. 25 мая, 10:31
    0
    const n=6;

    num=100;

    var arr:array[1 ... n] of integer;

    m, i, j:integer;

    begin

    Writeln ('zapolnite massiv: ') ;

    for i:=1 to n-1 do

    Read (arr[i]) ;

    Write ('pozitia v massive: ') ;

    Read (m) ;

    if (arr[m] mod 2) = 0

    then

    begin

    for i:=n-1 downto m+1 do

    arr[i+1]:=arr[i];

    arr[m+1]:=num end

    else

    begin for i:=n-1 downto m do

    arr[i+1]:=arr[i]; arr[m]:=num

    end;

    Write (' noviy massiw=: ') ;

    for i:=1 to n do

    Write (arr[i]:5) ;

    writeln;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «8. Дан целочисленный линейный массив. Вставить в него число 100 после m-го элемента, если этот элемент четный. В противном случае - перед ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Дан целочисленный линейный массив. Удалить из него последний четный элемент.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)