Задать вопрос
1 января, 10:19

Дан массив из N элементов. В массив В записать только не повторяющиеся элементы

+3
Ответы (1)
  1. 1 января, 10:53
    0
    Const nx = 50;

    Var A, B, D:array[1 ... nx]of integer; i, n, j, m, z, k, m1:integer;

    Begin

    WriteLn ('Введи количество элементов массива') ; Read (n) ;

    For i: = 1 to N do begin

    A[i]: = random (20) - 5; write (A[i]:3) ; end; writeln;

    For i: = 1 to N do begin

    z: = A[i]; k:=0;

    For j: = i+1 to N do

    if A[i] = A[j] then k: = k + 1;

    For j: = 1 to m do

    if A[i] = B[j] then k: = k + 1;

    For j: = 1 to m1 do

    if A[i] = D[j] then k: = k + 1;

    if k = 0 then begin

    m: = m + 1; B[m] : = z; end

    else begin m1: = m1 + 1; D[m1] : = z; end;

    end; writeln ('B') ;

    For i: = 1 to m do write (B[i]:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из N элементов. В массив В записать только не повторяющиеся элементы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)