Задать вопрос
14 апреля, 21:09

Объявить массив из 4 элементов в разделе переменных. Организовать ввод значений пользователем. Найти среднее значение элементов.

+2
Ответы (1)
  1. 14 апреля, 22:16
    0
    Пишу на паскале

    var cp:real;

    i, k, sum:integer;

    mass:array[1 ... 4] of integer;

    begin

    for i:=1 to 4 do

    begin

    write ('mass[', i,'] = ') ;

    read (mass[i]) ;

    k:=k+1;

    sum:=sum+mass[i];

    end;

    cp:=sum/k;

    writeln ('Среднее значение переменных равно ', cp) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Объявить массив из 4 элементов в разделе переменных. Организовать ввод значений пользователем. Найти среднее значение элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Организовать ввод чисел в массив E состоящий из 7 элементов ввод с клавиатуры сформировать новый массив К состоящий из элементов которые равны квадратам элементов массива Е вывести элементы массива Е найти и вывести номер минимального элемента
Ответы (1)
Задания. 1. Найти простейшую формулу от трёх переменных, принимающую значение 0 только на следующих наборах значений переменных: 7) А (0,0,0) = А (0,1,1) = А (1,0,1) = А (1,1,1) 2.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)