Задать вопрос
17 февраля, 00:49

В паскале написать программу:

Вывести среднее арифметическое двузначных четных чисел

+3
Ответы (2)
  1. 17 февраля, 02:20
    0
    Var i, k:integer;

    rez:real;

    begin

    for i:=10 to 99 do

    if (i mod 2) = 0 then

    begin

    k:=k+1;

    rez:=rez+i;

    end;

    rez:=rez/k;

    writeln (rez:0:1) ;

    end.
  2. 17 февраля, 03:09
    0
    Const

    n=20;

    var

    a:array[1 ... n]of integer;

    i, k:integer;

    s:real;

    begin

    for i:=1 to n do

    begin

    a[i]:=random (201) - 100;

    write (a[i]:4) ;

    if (a[i]>=10) and (a[i]<100) and (a[i]mod 2=0) then

    begin

    s:=s+a[i];

    k:=k+1;

    end;

    end; writeln;

    if k0 then

    writeln (s/k:4:2)

    else

    writeln ('нет четных двузначных') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В паскале написать программу: Вывести среднее арифметическое двузначных четных чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Найти среднее арифметическое двузначных чисел кратных 7 2. Найти среднее арифметическое первых 10 чисел делящихся на 5 (в паскале)
Ответы (1)
Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35; 35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов;
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.
Ответы (1)