Задать вопрос
11 ноября, 11:39

Напишите программу находящую среднее арифметическое четных чисел, вводимых с клавиатуры. задачу решить с помощью цикла с параметром

+1
Ответы (1)
  1. 11 ноября, 15:20
    0
    Program prl;

    uses crt;

    var i, n, summa:integer;

    srednee:real;

    a:arra[1 ... 100] of integer;

    begin

    write ('Введите кол-во четных элементов') ;

    readln (n) ;

    summa:=0;

    for i:=1 to n do begin

    write ('Введите ', i,' элемент:') ;

    readln (A[i]) ;

    summa:=summa+A[i];

    end;

    srednee:=summa / (n div 2) ;

    writeln ('Среднее арифметическое', srednee:3:2) ; / /

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу находящую среднее арифметическое четных чисел, вводимых с клавиатуры. задачу решить с помощью цикла с параметром ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
1. составить программу и алгоритм находящую сумму цифр трехзначного числа 2. составить программу и алгоритм находящую все простые делители заданного числа
Ответы (1)
Задание: 1) Перечислить виды циклов. 2) Конструкция цикла с параметром на языке программирования Pascal. 3) Известно ли число повторений в цикле с параметром? 4) Если известно, то указать формулу, по которой можно определить число повторений.
Ответы (1)
Для чего используются команды цикла? Как записывается команда цикла FOR? Как в цикле записать команду присваивания, чтобы она вычисляла сумму чисел? Количество?
Ответы (2)