Задать вопрос
6 января, 03:23

Помогите написать программу в паскале.

В заданном массиве найти количество чётных чисел. Вывести исходный массив и результат.

+1
Ответы (1)
  1. 6 января, 07:01
    0
    Вариант с вводом элементов:

    Program prog;

    uses crt;

    var a: array [0 ... 999] of integer;

    i, k, n: integer;

    begin

    clrscr;

    write ('Размер массива n = ') ;

    readln (n) ;

    writeln;

    for i:=1 to n do

    begin

    write ('a[', i,'] = ') ;

    readln (a[i]) ;

    end;

    for i:=1 to n do

    if a[i] mod 2 = 0 then k:=k+1;

    writeln;

    writeln ('Количество четных чисел k = ', k) ;

    end.

    Вариант с рандомными элементами:

    Program prog;

    uses crt;

    var a: array [0 ... 999] of integer;

    i, k, n: integer;

    begin

    clrscr;

    randomize;

    write ('Размер массива n = ') ;

    readln (n) ;

    writeln;

    for i:=1 to n do

    begin

    a[i]:=random (100) - 50;

    writeln ('a[', i,'] = ', a[i]) ;

    end;

    for i:=1 to n do

    if a[i] mod 2 = 0 then k:=k+1;

    writeln;

    writeln ('Количество четных чисел k = ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в паскале. В заданном массиве найти количество чётных чисел. Вывести исходный массив и результат. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35; 35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов;
Ответы (1)
составить программу в Паскале Массив A (M, N) заполнить случайными числами из промежутка [-15; -8] и подсчитать произведение элементов чётных строк. Исходный массив и результат вывести на экран
Ответы (1)
1. Задать массив из 10 элементов с пом. генератора случ. Чисел из интервала (10,30). Увеличить каждое число в массиве три раза. Вывести на экран оба массив (результат и исходный) 2. Дано 2 массива из 80 элементов.
Ответы (1)