Задать вопрос
7 февраля, 01:07

составить программу в Паскале

Массив A (M, N) заполнить случайными числами из промежутка [-15; -8] и подсчитать произведение элементов чётных строк. Исходный массив и результат вывести на экран

+1
Ответы (1)
  1. 7 февраля, 02:42
    0
    Вместо 20 можно подставить любое число, 20 соответствует M, N

    program new;

    var a:array [1 ... 20,1 ... 20] of integer; i, j, sum:integer;

    begin

    randomize;

    for i=1 to 20 do

    begin

    for j=1 to 20 do

    begin

    a[i, j]:=random (8) - 15

    end;

    end;

    for i=2 to 20 do

    begin

    for j=1 to 20 do

    begin

    sum:=sum+a[i, j];

    i:=i+2;

    end;

    end;

    for i=1 to 20 do

    begin

    for j=1 to 20 do

    begin

    write (a[i, j]) ;

    end;

    writeln;

    end;

    writeln ('Сумма равна ', sum:8) ;

    end.

    P. S.

    Делал без паскаля если какие то ошибки то пиши
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу в Паскале Массив A (M, N) заполнить случайными числами из промежутка [-15; -8] и подсчитать произведение элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив из 25 элементов заполнить случайными числами из диапазона [-100 ... 100] и вывести на экран. Найдите элемент массива с максимальной суммой цифр. 2. Массив из 20 элементов заполнить случайными числами из диапазона [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)