Задать вопрос
24 апреля, 21:02

Запишите программу для вычисления суммы квадратов положительных элементов массива действительных чисел. Количество элементов массива n (5

+3
Ответы (1)
  1. 24 апреля, 21:08
    0
    Var n:array[1 ... 5] of integer; i, s:integer;

    begin

    for i:=1 to 5 do read (n[i]) ;

    for i:=1 to 5 do if n[i]>0 then s:=s+sqr (n[i]) ;

    writeln; write ('S = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Запишите программу для вычисления суммы квадратов положительных элементов массива действительных чисел. Количество элементов массива n (5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Составить программу вычисления, A - сумма положительных элементов массива; B - номер наименьшего элемента массива; C - количество элементов массива кратных пяти. Полученные значения элементов А, B, C, W вывести на печать. (Паскаль)
Ответы (1)