Задать вопрос
11 октября, 08:59

Решение нужно в паскале. составьте программу вычисления суммы элементов двумерного массива A (N, N), расположенных под побочной диагональю

+2
Ответы (1)
  1. 11 октября, 09:35
    0
    Const n=4;

    Var x:array [1 ... n, 1 ... n] of integer;

    s, i, j:integer;

    begin

    randomize;

    for i:=1 to n do begin

    for j:=1 to n do begin

    x[i, j] : = random (100) ;

    write (x[i, j]:6) ;

    end;

    writeln;

    end;

    s:=0;

    for i:=1 to n do

    for j: = 1 to n do

    if i + j < n + 1

    then

    s : = s + x[i, j];

    writeln ('s=', s) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решение нужно в паскале. составьте программу вычисления суммы элементов двумерного массива A (N, N), расположенных под побочной диагональю ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Нужно разработать программу для определения требуемых величин в элементах двумерного массива, расположенных ниже главной и побочной диагонали. Имя массива J Размер 32 Программа должна реализовывать следующие функции: 1. Сумма всех чисел 2.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)