Задать вопрос
1 декабря, 12:42

Составить задачу в Паскале. Составьте программу вычисления суммы нечетных элементов одномерного массива А (Т). Массив заполнить случайным образом

+3
Ответы (1)
  1. 1 декабря, 15:36
    0
    Const n=10;

    Var a:array [1 ... n] of integer;

    s, t:integer;

    begin

    randomize;

    for t:=1 to n do

    begin

    a[t] : = random (100) ;

    write (a[t]:6) ;

    end;

    writeln;

    s:=0;

    for t:=1 to n do

    if a[t] mod 2=1

    then

    s:=s+a[t];

    writeln ('Summa=', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить задачу в Паскале. Составьте программу вычисления суммы нечетных элементов одномерного массива А (Т). Массив заполнить случайным ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)