Задать вопрос
19 мая, 08:25

Даны целые числа а1, ..., аn (в этой последовательности могут быть повторяющиеся члены). получить все числа, которые входят в последовательность по одному разу.

+2
Ответы (1)
  1. 19 мая, 11:50
    0
    Само собой, числа a1 ... an надо поместить в массив. Если его упорядочить по возрастанию (или убыванию), то элементы с одинаковыми значениями окажутся рядом и их легко будет пропустить.

    var

    a:array[1 ... n] of integer;

    i, j, t:integer;

    begin

    { инициализация массива }

    Randomize;

    Writeln ('Элементы массива') ;

    for i : = 1 to n do

    begin

    a[i]:=Random (10) ;

    Write (a[i]:3) ;

    end;

    Writeln;

    { сортировка по возрастанию методом пузырька }

    for i : = 1 to n-1 do

    for j : = 1 to n-i do

    if a[j] > a[j+1] then

    begin t : = a[j]; a[j] : = a[j+1]; a[j+1] : = t end;

    { вывод неповторяющихся значений }

    Writeln ('Уникальные значения элементов') ;

    t:=a[1]; Write (t:3) ;

    for i:=2 to n do

    if a[i]t then begin t:=a[i]; Write (t:3) end;

    Writeln

    end.

    Тестовое решение:

    Элементы массива

    9 6 1 6 1 4 5 9 1 2 6 7 7 6 1 7 7 8 0 8

    Уникальные значения элементов

    0 1 2 4 5 6 7 8 9
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны целые числа а1, ..., аn (в этой последовательности могут быть повторяющиеся члены). получить все числа, которые входят в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Написать программу в Pascal даны целые числа а1 ... аn. Если в данной последовательности ни одно четное число не расположено после нечетного. то получить все отрицательные члены последовательности иначе-положительное.
Ответы (1)
1. Дана последовательность из N (2
Ответы (1)
Помогите решить задачу на c++. Последовательность из нулей и единиц четной длины назовем справедливой, если на четных местах этой последовательности столько же единиц, сколько на нечетных.
Ответы (1)
Даны последовательности А, В, С. В каждой из них 20 целых чисел. В той последовательности, где больше всего 0 (считая что такая последовательность одна), все 0 заменить наибольшим значением данной последовательности (теория алгоритмов)
Ответы (1)