Задать вопрос
14 марта, 01:14

Написать программу в Pascal даны целые числа а1 ... аn. Если в данной последовательности ни одно четное число не расположено после нечетного. то получить все отрицательные члены последовательности иначе-положительное.

+2
Ответы (1)
  1. 14 марта, 03:55
    0
    var

    a: array[1 ... 50] of integer;

    i, f, n: integer;

    begin

    write ('n=') ;

    readln (n) ;

    for i : = 1 to n do

    begin

    write ('a', i, '=') ;

    readln (a[i]) ;

    end;

    f : = 0;

    writeln;

    for i : = 1 to n - 1 do

    if (a[i] mod 2 0) and (a[i + 1] mod 2 = 0) then f : = 1;

    if f = 0 then

    begin

    for i : = 1 to n do

    if a[i] < 0 then write (a[i]:4) ;

    end

    else

    for i : = 1 to n do

    if a[i] > 0 then write (a[i]:4) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Pascal даны целые числа а1 ... аn. Если в данной последовательности ни одно четное число не расположено после ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать в паскале! Ввести три целых числа x, y, z. Если хотя бы одно из них четное, то первому четному числу присвоить значение произведения этих чисел.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Задача 2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется четное число.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет минимальное четное число. Программа получает на вход кол-во чисел в последовательности, а затем сами числа. В последовательности всегда имеется четное число.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)