Задать вопрос
8 июня, 17:44

Найти в массиве все пары зеркальных элементов (элементов, имеющих один модуль, но разный знак).

+3
Ответы (1)
  1. 8 июня, 19:54
    0
    Const nx = 30; var C:Array[1 ... nx]of integer;

    r, i, n, m, max, k, el:integer;

    Begin

    Randomize;

    write ('Введите количество элементов') ; Readln (n) ;

    for r:=1 to n do begin

    C[r]:=random (100) - 50; write (C[r]:4) ; end;

    writeln;

    for r:=1 to n do begin

    if 0 < C[r] then begin

    for i:=r to n do begin

    if (0 > C[i]) and (abs (C[i]) = C[r]) then writeln (r:3, C[r]:4,' ', i:3, C[i]:4) ; end; end;

    if 0 > C[r] then begin

    for i:=r to n do begin

    if (0 < C[i]) and (C[i] = abs (C[r])) then writeln (r:3, C[r]:4,' ', i:3, C[i]:4) ; end; end; end; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти в массиве все пары зеркальных элементов (элементов, имеющих один модуль, но разный знак). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)