Задать вопрос
17 декабря, 14:49

Сделать программу в Паскале АБС по следующей задаче.

Найти стороны прямоугольного треугольника, если катит больше другого в 2 раза.

+3
Ответы (1)
  1. 17 декабря, 17:11
    0
    Var

    a, b, c:real;

    begin

    Write ('Введите длину меньшего катета - > ') ; Readln (a) ;

    b:=2*a; c:=sqrt (a*a+b*b) ;

    Writeln ('Длина большего катета ', b,', длина гипотенузы ', c)

    end.

    Тестовое решение:

    Введите длину меньшего катета - > 15.63

    Длина большего катета 31.26, длина гипотенузы 34.9497424883217
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сделать программу в Паскале АБС по следующей задаче. Найти стороны прямоугольного треугольника, если катит больше другого в 2 раза. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу на Паскале 1. Найти объем параллелепипеда (стороны ввести с клавиатуры) 2. Высота треугольника равно 7 см, а основание 3 см. Написать программу, вычисляющую площадь треугольника 3.
Ответы (1)
Составьте программу (на паскале), вычисляющую площадь S прямоугольного треугольника по заданным длинам двух катетов a, b. Вывод на экран оформить следующим образом: введите два катета в см: 13.5 17.2 площадь прямоугольного треугольника равна 116.
Ответы (1)
Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс
Ответы (1)
Написать программу к следующей задаче: Вводится с клавиатуры число, которое обозначает количество суток. Написать программу расчета количества часов, количества минут и количества секунд по заданному количеству суток.
Ответы (1)
Зачетная работа по информатике. 1. Написать программу вычисления площади прямоугольника (на паскале). 2. Написать программу вычесления ускорения тела (на паскале).
Ответы (1)