Задать вопрос
19 декабря, 20:44

Во введенной строке подсчитайте количество символов "*" и символов "!".

Информатика. Паскаль. Строки

+5
Ответы (1)
  1. 19 декабря, 21:00
    0
    Var

    s:string;

    i, n1, n2:integer;

    begin

    Write ('Введите строку: ') ; Readln (s) ;

    n1:=0; n2:=0;

    for i:=1 to Length (s) do

    case s[i] of

    '*':Inc (n1) ;

    '!':Inc (n2)

    end;

    Writeln ('Найдено * : ', n1,',!: ', n2)

    end.

    Тестовое решение:

    Введите строку: Это * просто * ! * тестовая строчка!

    Найдено * : 3,!: 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Во введенной строке подсчитайте количество символов "*" и символов "!". Информатика. Паскаль. Строки ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программа в Pascal 1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м. 2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о
Ответы (1)
Составить программу в Pascal 1) в строке, введенной с клавиатуры, все буквы И заменить на % 2) из строки, введенной с клавиатуры, удалить все символы, начиная с середины.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
5.1 Ввести с клавиатуры строку символов. Признак окончания ввода строки - нажатие клавиши "Ввод". Программа должна определить длину введенной строки L, и, если длина L >6, то выделяется подстрока в { } скобках. 5.2 Дана строка.
Ответы (1)
1) Сколько символов в тексте, если 1) Сколько символов в тексте, если мощность алфавита-64 символа, а объем информации, содержащийся в нем-1,5 Кбайт. 2) Сообщение занимает 3 страницы по 25 строк. В каждой строке записано по 60 символов.
Ответы (1)