Задать вопрос
24 апреля, 04:13

Каждая бактерия делится на 2 в течение одной минуты. В начальный момент имеется одна бактерия. Составить программу, которая рассчитывает кол-во бактерий на заданное Вам целое значение момента времени. pascal abc

+5
Ответы (1)
  1. 24 апреля, 08:03
    0
    Var t, a, i: integer;

    begin

    write ('Введите количество минут: ') ;

    read (t) ;

    a:=1;

    for i:=1 to t do

    begin

    a:=a*2;

    writeln ('Бактерий через ', i, ' минут: ', a) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Каждая бактерия делится на 2 в течение одной минуты. В начальный момент имеется одна бактерия. Составить программу, которая рассчитывает ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Каждая бактерия делится на две в течение одной минуты. В начальный момент времени имеется одна бактерия. Составьте программу, которая рассчитывает количество бактерий на заданное вами целое значение момента времени.
Ответы (1)
Каждая бактерия делится на две в течение одной минуты. В начальный момент имеется одна бактерия. Составьте программу, которая расчитает количество бактерий на заданное вами целое значение момента времени (15 минут, 7 мин и т. п.)
Ответы (1)
Каждая бактерия делится на 2 через каждые 3 минуты. В начальный момент имеется 1 бактерия. Сколько их будет через n минут. N вводится пользователем. Составить программу с помощью цикла со счётчиком. (For счётчик:=нач.
Ответы (1)
Каждая бактерия делится на две в течении одной минуты в начальный момент времени имеется одна бактерия сколько их станет через 15 минут
Ответы (1)
Каждая бактерия делится на 2 через каждые 2 минуты. В начальный момент имеется 1 бактерия. Написать программу, определяющую сколько их будет через n минут.
Ответы (1)