Задать вопрос
17 мая, 07:18

Каждая бактерия делится на две в течение одной минуты. В начальный момент времени имеется одна бактерия. Составьте программу, которая рассчитывает количество бактерий на заданное вами целое значение момента времени.

+5
Ответы (1)
  1. 17 мая, 09:43
    0
    Var bak:integer;

    begin

    readln (bak) ; / / Вбиваем требуемое кол-во минут

    /*каждую минуту кол-во бактерий увеличивается вдвое, т. к. вначале мы имеем всего 1 бактерию, то просто умножаем кол-во минут на 2 * /

    bak:=bak*2;

    writeln (bak) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Каждая бактерия делится на две в течение одной минуты. В начальный момент времени имеется одна бактерия. Составьте программу, которая ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Каждая бактерия делится на 2 в течение одной минуты. В начальный момент имеется одна бактерия. Составить программу, которая рассчитывает кол-во бактерий на заданное Вам целое значение момента времени. pascal abc
Ответы (1)
Каждая бактерия делится на две в течение одной минуты. В начальный момент имеется одна бактерия. Составьте программу, которая расчитает количество бактерий на заданное вами целое значение момента времени (15 минут, 7 мин и т. п.)
Ответы (1)
Каждая бактерия делится на две в течении одной минуты в начальный момент времени имеется одна бактерия сколько их станет через 15 минут
Ответы (1)
Каждая бактерия делится на 2 через каждые 3 минуты. В начальный момент имеется 1 бактерия. Сколько их будет через n минут. N вводится пользователем. Составить программу с помощью цикла со счётчиком. (For счётчик:=нач.
Ответы (1)
Каждая бактерия делится на 2 через каждые 2 минуты. В начальный момент имеется 1 бактерия. Написать программу, определяющую сколько их будет через n минут.
Ответы (1)