Задать вопрос
6 апреля, 13:36

Написать программу определяющую является ли окружность с радиусом r вписанной или описанной около квадрата

+4
Ответы (1)
  1. 6 апреля, 15:32
    0
    Var

    a, r, rvp, rop:real;

    begin

    Write ('Введите сторону квадрата и радиус окружности: ') ;

    Readln (a, r) ;

    rvp:=a/2; rop:=a*sqrt (2) / 2;

    if r
    else

    if r=rvp then Writeln ('Введен радиус вписанной окружности')

    else

    if r
    else

    if r=rop then Writeln ('Введен радиус описанной окружности')

    else Writeln ('Окружность расположена вне описанной')

    end.

    Тестовое решение:

    Введите сторону квадрата и радиус окружности: 8 5

    Окружность расположена между вписанной и описанной
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу определяющую является ли окружность с радиусом r вписанной или описанной около квадрата ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Составить программу, определяющую, является ли данное утверждение истинным: Двузначное число А начинается на 3 Составить программу, определяющую, является ли данное утверждение истинным: Ровно одно из чисел А и В не превышает 100
Ответы (1)
1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных чисел, 2). Дан массив из n целых чисел. Напишите программу определяющую каких элементов в точке больше положительных или отрицательных
Ответы (1)
1. Напишите программу, определяющую сумму S=1+2+3+4 ... + 99 2. Напишите программу, определяющую произведение P=1*2*3*4 ... * 10 На Паскаль За ранее благодарна
Ответы (1)