Задать вопрос
14 ноября, 09:57

Вычислить интеграл функции f (x) = 3x^2-2x на интервале (0, 2) методом Симпсона. Шаг интегрирования взять равным h=0.5

+1
Ответы (1)
  1. 14 ноября, 10:07
    0
    Type

    fun=function (p:real) : real;

    function f (x:real) : real;

    begin

    f:=3*sqr (x) - 2*x;

    end;

    function Simpson (a, b, h:real; ff:fun) : real;

    var

    m, n, mn:integer;

    s:real;

    begin

    n:=Trunc ((b-a) / h) + 1;

    s:=f (a) + f (b) ;

    mn:=4;

    for m:=1 to n-2 do begin

    s:=s+mn*f (a+h*m) ;

    if mn=4 then mn:=2 else mn:=4;

    end;

    Simpson:=s*h/3;

    end;

    var

    a, b, h:real;

    begin

    a:=0; b:=2; h:=0.5;

    Writeln ('y=', Simpson (a, b, h, f))

    end.

    Результат выполнения программы:

    y=4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить интеграл функции f (x) = 3x^2-2x на интервале (0, 2) методом Симпсона. Шаг интегрирования взять равным h=0.5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
Решить задачи с помощью Паскаля: 1. Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и отсортировать его по последней цифре. 2. Заполнить массив из 10 элементов случайными числами в интервале [0 ...
Ответы (2)
Паскаль - массивы. Написать программу, которая считает среднее число шагов в двоичном поиске для массива из 32 элементов в интервале [0,100]. Для поиска использовать 1000 случайных чисел в этом же интервале.
Ответы (1)
Составить программу, которая просит ввести любое число в интервале от 1 до 30, затем подсчитывает произведение чисел кратных 5 в интервале от 0 до введённого числа.
Ответы (1)
Помогите решить задачи по икт. 1 заполнителя массив из 10 элементов случайными числами в интервале [-10 ... 10] и выполнить циклический сдвиг вправо. 2 заполнить массив из 10 элементов случайными числами в интервале [0 ...
Ответы (1)