Задать вопрос
6 июня, 16:05

Напишите программу поиска минимального и максимального элементов матрицы. Программа должна менять максимальный и минимальный элементы между собой и выводить на экран исходную и преобразованную матрицы (Турбо Паскаль)

+1
Ответы (1)
  1. 6 июня, 19:29
    0
    Program al;

    var a: array[1 ... 32000] of integer;

    buf:integer;

    i, n, min, max:integer;

    begin

    writeln ('n=') ;

    readln (n) ;

    writeln ('vvedite massiv=') ;

    for i : = 1 to n do

    readln (a[i]) ;

    min:=1;

    max:=1;

    for i:=2 to n do

    begin

    if a[min]>a[i] then

    min:=i;

    if a[max]
    max:=i;

    end;

    buf:=a[min];

    a[min]:=a[max];

    a[max]:=buf;

    writeln ('Massiv posle obmena maxmin') ;

    for i:=1 to n do

    write (a[i]:4) ;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу поиска минимального и максимального элементов матрицы. Программа должна менять максимальный и минимальный элементы между ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25 Программа должна: 1) выводить на экран сначала все элементы массива, стоящие на
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Составьте программу, которая вводит с клавиатуры 8 целых неотрицательных чисел (каждое число - с новой строки отдельной командой "ввод"), записывает их в массив, выводит на экран сначала в прямом порядке все без исключения элементы массива, затем, в
Ответы (1)
1. Имеется одномерный массив размерностью 20, заполненный рандомными числами на отрезке от 1 до 20. Требуется удалить из него максимальный и минимальный элементы Примечание: Алгоритм удаления: сдвигаются все элементы на 1 позицию влево, начиная с
Ответы (1)
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)