Задать вопрос
3 мая, 15:48

Дан массив элементов А[15]. Найти суммы элементов с 1 до 5, с 6 до 10, с 11 до 15 и вычислить произведение этих трех сумм.

+2
Ответы (1)
  1. 3 мая, 19:03
    0
    Program al;

    const n=15;

    var a:array[1 ... n ] of integer;

    s1, s2, s3, p, i:integer;

    begin

    writeln ('vvedite massiv=') ;

    for i: = 1 to n do

    readln (a[i]) ;

    s1:=0;

    s2:=0;

    s3:=0;

    p:=1;

    for i : = 1 to 5 do

    s1:=s1+a[i];

    for i: = 6 to 10 do

    s2:=s2+a[i];

    for i: = 11 to 15 do

    begin

    s3: = s3+a[i];

    p:=s1*s2*s3;

    end;

    writeln ('s1=', s1,' s2=', s2,' s3=', s3,' p=', p) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив элементов А[15]. Найти суммы элементов с 1 до 5, с 6 до 10, с 11 до 15 и вычислить произведение этих трех сумм. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)