Задать вопрос
4 марта, 11:45

Написать процедуру и функцию, находящие среднее арифметическое двух чисел.

+3
Ответы (2)
  1. 4 марта, 14:05
    0
    Function avg (a, b:real) : real;

    begin

    avg: = (a+b) / 2

    end;

    procedure avg2 (a, b:real; var c:real) ;

    begin

    c: = (a+b) / 2

    end;

    var

    a, b, c:real;

    begin

    Write ('Введите два произвольных числа: ') ; Readln (a, b) ;

    Writeln ('Среднее значение, найденное функцией: ', avg (a, b)) ;

    avg2 (a, b, c) ;

    Writeln ('Среднее значение, найденное процедурой: ', c)

    end.

    Тестовое решение:

    Введите два произвольных числа: 11.7 14.519

    Среднее значение, найденное функцией: 13.1095

    Среднее значение, найденное процедурой: 13.1095
  2. 4 марта, 15:02
    0
    Function average (x, y: real) ;

    var c: real;

    begin

    c : = (x + y) / 2;

    writeln ('Среднее арифметическое двух чисел с помощью функции: ', c) ;

    end;

    procedure average_p (x, y: real) ;

    var c: real;

    begin

    c : = (x + y) / 2;

    writeln ('Среднее арифметическое двух чисел с помощью процедуры: ', c) ;

    end;

    var a, b: real;

    begin

    write ('Введите число a: ') ;

    readln (a) ;

    write ('Введите число b: ') ;

    readln (b) ;

    average (a, b) ;

    average_p (a, b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать процедуру и функцию, находящие среднее арифметическое двух чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Описать процедуру Mean (X, Y, AMean, GMean), вычисляющую среднее арифметическое AMean = (X+Y) / 2 и среднее геометрическое двух положительных чисел X и Y (X и Y - входные, AMean и GMean - выходные параметры вещественного типа).
Ответы (1)
1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров , в каком из двух введенных с клавиатуры целых чисел произведение цифр больше.
Ответы (1)
Составить процедуру определения среднего арифметического значения элементов одномерного массива А[m]. Используя процедуру, определить среднее арифметическое побочной диагонали квадратной матрицы B[m, m].
Ответы (1)
Написать в Паскале процедуру с изменяемым параметром. помогите хотя бы с одним. Уровень A. Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания. Пример: Введите три натуральных числа: 10 15 5 5 10 15 Уровень B.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)