Задать вопрос
16 ноября, 21:47

Дано действительное число Х. Напишите программу для вычисления:

Числа Х, округлённого до ближайшего целого

Числа Х без дробных цифр

+1
Ответы (1)
  1. 16 ноября, 22:51
    0
    В Паскале есть функция Round, которая использует следующий "стандартный" алгоритм округления:

    Если число положительное, то при величине его дробной части меньше 0.5, она просто отбрасывается, если больше - отбрасывается и к числу прибавляется единица. Если число отрицательное, то при абсолютной величине его дробной части меньше 0.5, она просто отбрасывается, если больше - из числа вычитается единица.

    А функция Trunc возвращает целую часть числа.

    var

    p:real;

    begin

    Write ('Введите число: ') ; Read (p) ;

    Writeln ('Округленное значение: ', Round (p),', целая часть: ', Trunc (p))

    end.

    Тестовое решение:

    Введите число: - 12.74

    Округленное значение: - 13, целая часть: - 12

    Введите число: 12.93

    Округленное значение: 13, целая часть: 12

    Введите число: 9.4323

    Округленное значение: 9, целая часть: 9
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано действительное число Х. Напишите программу для вычисления: Числа Х, округлённого до ближайшего целого Числа Х без дробных цифр ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Опишите переменные для размещения в них: - пола человека (один символ) ; - целого положительного двузначного числа; -целого положительного трёхзначного числа; -целого положительного четырёхзначного числа; -небольшого вещественного числа;
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)