Задать вопрос
1 октября, 18:58

Паскаль

Дан массив А (50) целых чисел. Найти сумму и количество тех элементов массива, которые при делении на 7 дают остаток 1, 2 или 5.

+2
Ответы (1)
  1. 1 октября, 21:48
    0
    Программа может выглядеть так:

    uses Crt;

    const n=50;

    type Vec=array [1 ... n] of integer;

    var A: Vec;

    i, Sum, Col: integer;

    begin

    ClrScr;

    Randomize;

    Sum:=0;

    Col:=0;

    for i:=1 to n do

    begin

    A[i]:=10+random (40) ;

    Write (A[i]: 4) ;

    if (i mod 10 = 0) then WriteLn;

    if (A[i] mod 7 = 1) or (A[i] mod 7 = 2) or (A[i] mod 7 = 5) then

    begin

    Sum:=Sum+A[i];

    Col:=Col+1;

    end;

    end;

    WriteLn;

    WriteLn (' Sum = ', Sum) ;

    WriteLn (' Col = ', Col) ;

    ReadLn;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль Дан массив А (50) целых чисел. Найти сумму и количество тех элементов массива, которые при делении на 7 дают остаток 1, 2 или 5. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)