Задать вопрос
9 октября, 12:15

Ввести натуральное число и определить, верно ли, что сумма его цифр равна10.

+4
Ответы (1)
  1. 9 октября, 12:52
    0
    Program G;

    Uses Crt;

    Var summ, x, m, back: integer;

    Begin

    ClrScr;

    Writeln ('Введите натуральное число.') ;

    Readln (x) ;

    Summ:=0;

    Back:=x;

    While x>0 do

    Begin

    m:=x mod 10;

    x:=x div 10;

    summ:=summ+m;

    End;

    If summ=10 then Writeln ('Сумма цифр числа ', back, ' равна 10.')

    Else Writeln ('Сумма чисел числа ', back, ' не равна 10.') ;

    Readln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести натуральное число и определить, верно ли, что сумма его цифр равна10. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)
Python. Уровень B. Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите натуральное число: 12342 Нет. Пример: Введите натуральное число: 12245 Да.
Ответы (1)