Задать вопрос
31 марта, 03:33

Написать фрагмент программы, подсчитывающий сумму только положительных из трех данных чисел.

+4
Ответы (1)
  1. 31 марта, 06:35
    0
    1 вариант:

    If (a>0) or (a=0) and (b>0) or (b=0) and (c>0) or (c=0) Then s:=a+b+c Else

    If (a>0) or (a=0) and (b>0) or (b=0) and (c<0) Then s:=a+b Else

    If (a>0) or (a=0) and (c>0) or (c=0) and (b<0) Then s:=a+c Else

    If (b>0) or (b=0) and (c>0) or (c=0) and (a<0) Then s:=b+c Else

    If (a<0) and (b0) or (c=0) Then s:=c Else

    If (a<0) and (c0) or (b=0) Then s:=b Else s:=a;

    2 вариант:

    If (a>0) or (a=0) Then s:=s+a;

    If (b>0) or (b=0) Then s:=s+b;

    If (c>0) or (c=0) Then s:=s+c;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать фрагмент программы, подсчитывающий сумму только положительных из трех данных чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Вычислить значения функции y={x2 + 5, при x>3 x-8, при x< = 3 2. Написать фрагмент программ, подсчитывающий сумму только положительных из трех данных чисел
Ответы (1)
1) дан фрагмент программы: For i: = 1 to 10 do begin Writeln ('Hello, world!') End Что выполняет данный фрагмент? 2) дан фрагмент программы: For i: = 1 to 15 do begin Writeln (i) End Что выполняет данный фрагмент?
Ответы (1)
Какие программы относятся к прикладным программам? A. Программы общего назначения. B. Специальные профессиональные программы. C. Языки программирования. D. Сервисные программы. E. Операционные системы.
Ответы (1)
Антивирусные программы-это 1. программы сканирования и распознавания 2. программы выявляющие и лечащие компьютерные вирусы 3. программы только выявляющие вирусы 4. программы-архиваторы разархиваторы
Ответы (1)
Написать программу, которая вычисляет сумму первых n целых положительных целых чисел. Количество суммируемых чисел должно вводиться во время работы программы.
Ответы (1)