Задать вопрос
30 января, 09:40

Дано целое число N (> 0). Найти наименьшее целое положительное число K, квадрат которого превосходит N: K^2> N. Функцию извлечения квадратного корня не использовать.

+5
Ответы (1)
  1. 30 января, 11:34
    0
    Var

    n, k, i:integer;

    begin

    Write ('Введите натуральное n: ') ; Readln (n) ;

    if n<4 then k:=2

    else begin

    i:=1; k:=1;

    while i<=n do begin n:=n-i; i:=i+2; inc (k) end;

    end;

    Writeln ('k=', k)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое число N (> 0). Найти наименьшее целое положительное число K, квадрат которого превосходит N: K^2> N. Функцию извлечения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачу на языке Pascal, применяя цикл с предусловием Дано целое положительное число N. Найти наименьшее целое положительное число K, квадрат которого превосходит N. Функцию извлечения квадратного корня не использовать.
Ответы (2)
Pascal ABC while 7 Дано целое число N (>1). Найти наименьшее целое положительное число K, квадрат которого превосходит N:K^2 меньше или равно N. Функцию извлечения квадратного корня не использовать.
Ответы (1)
Ано целое число N (>0). найти наименьшее целое положительное число K, квадрат которого превосходит N: K^2>N. функцию извлечения квадратного корня не использовать. Решить через repeat
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)