Задать вопрос
31 января, 05:05

Pascal

составить программу с полным ветвлением

y=x*x если x<2

y=x*x*x если x>2

y=2+x если x=2

+4
Ответы (1)
  1. 31 января, 08:36
    0
    Program dfgd;

    var

    x: integer;

    y: real;

    begin

    write ('Введите х: ') ;

    readln (x) ;

    if x < 2

    then y : = sqr (x)

    else

    if x > 2

    then y : = power (x, 3)

    else y : = 2 + x;

    writeln ('y=', y) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal составить программу с полным ветвлением y=x*x если x2 y=2+x если x=2 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Нарисуйте блок-схемы и напишите на АЯ два варианта алгоритма решения задачи: выбрать из двух числовых величин наибольшее значение. Первый вариант с полным ветвлением, второй вариант - с неполным ветвлением.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Ответить на следующие вопросы: 1) Что означает фраза: "задачи с ветвлением"? 2) Как записывается полный условный оператор? 3) Как записывается неполный условный оператор? 4) Какие математические действия можно выполнять в задачах с ветвлением?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Чем отличается алгоритм с ветвлением от циклического? Как сделать алгоритм с ветвлением?
Ответы (1)