Задать вопрос
2 апреля, 15:07

Дан целочисленный массив из 6 элементов.

1. Найти и вывести номер первого элемента массива, который имеет нечётное значение.

2. Найти и вывести сумму элементов массива, которые делятся на последний элемент и меньше, чем первый.

+4
Ответы (1)
  1. 2 апреля, 16:21
    0
    Var mas: array [1 ... 6] of integer;

    var i, b, sum: integer;

    begin

    for i:=1 to 6 do mas[i]:=random (101) ;

    b:=0;

    while i<=6 do if mas[i] mod 20 then

    begin

    b:=i;

    i:=7;

    end

    else inc (i) ;

    sum:=0;

    for i:=1 to 6 do if (mas[i] mod 2=0) and (mas[i]
    writeln (b) ;

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив из 6 элементов. 1. Найти и вывести номер первого элемента массива, который имеет нечётное значение. 2. Найти и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)