Задать вопрос
18 февраля, 11:42

Нужно заполнить массив из 10 элементов случайными числами в интервале [-10 ... 10] и найти в нем 2 максимальных элемента и их номера. написать программу на языке паскаль

+4
Ответы (1)
  1. 18 февраля, 13:50
    0
    Const

    n=10; var

    a:array[1 ... n]of integer;

    i, max1, max2, im1, im2:integer;

    begin for i:=1 to n do

    begin

    a[i]:=random (21) - 10;

    write (a[i]:4) ;

    end;

    max1:=a[1]; im1:=1;

    for i:=1 to n do

    if a[i]>max1 then

    begin

    max1:=a[i];

    im1:=i;

    end;

    for i:=1 to n do

    if (a[i]<>max2) then

    begin

    max2:=a[i];

    im2:=i;

    end;

    writeln;

    writeln ('i: ', im1,' max1: ', max1,' i: ', im2,' max2: ', max2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно заполнить массив из 10 элементов случайными числами в интервале [-10 ... 10] и найти в нем 2 максимальных элемента и их номера. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить задачи с помощью Паскаля: 1. Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и отсортировать его по последней цифре. 2. Заполнить массив из 10 элементов случайными числами в интервале [0 ...
Ответы (2)
Помогите решить задачи по икт. 1 заполнителя массив из 10 элементов случайными числами в интервале [-10 ... 10] и выполнить циклический сдвиг вправо. 2 заполнить массив из 10 элементов случайными числами в интервале [0 ...
Ответы (1)
С помощью Паскаля: 1. Заполните массив случайными числами в интервале [0; 100] и подсчитайте отдельно среднее значение всех элементов, которые меньше 50, и среднее значение всех элементов, которые больше или равны 50. 2.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)