Задать вопрос
8 октября, 02:53

Напишите программу, которая запрашивает у пользователя ввод чисел, пока не будет нажата цифра "ноль". На экран выводит сумму всех введенных чисел

+3
Ответы (2)
  1. 8 октября, 03:51
    0
    Program numSum;

    var inp, sum:longint;

    begin

    repeat

    readln (inp) ;

    sum:=sum+inp;

    until inp=0; write ('Sum - ', sum) ; readln;

    end.
  2. 8 октября, 04:37
    0
    Var a, s:integer;

    begin

    writeln ('Введите целое число') ;

    a:=1;

    while a0 do

    begin

    readln (a) ;

    s:=a+s;

    end;

    writeln ('Сумма всех введенных чисел = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая запрашивает у пользователя ввод чисел, пока не будет нажата цифра "ноль". На экран выводит сумму всех введенных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1. Написать командный файл, который: • запрашивает у пользователя текущий курс доллара • запрашивает у пользователя сумму в рублях • выводит сумму в долларах по текущему курсу
Ответы (1)
Задание 1 Напишите программу, которая спрашивает у пользователя два слова и выводит их разделёнными запятой. Задание 2 Напишите программу, которая запрашивает три целых числа a, b и x и выводит True, если x лежит между a и b, иначе - False.
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)