Задать вопрос
9 августа, 00:43

Дано трехзначное число, узнать есть ли в числе цифра 4 или 7? паскаль. составьте программу

+2
Ответы (1)
  1. 9 августа, 03:20
    0
    Var n, a, b, c:integer;

    begin

    read (n) ;

    a:=n div 100;

    b:=n div 10 mod 10;

    c:=n mod 10;

    if (a=4) or (b=4) or (c=4) then writeln ('в числе есть цифра 4') ;

    if (a=7) or (b=7) or (c=7) then writeln ('в числе есть цифра 7') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано трехзначное число, узнать есть ли в числе цифра 4 или 7? паскаль. составьте программу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
Напишите программу, которая возводит в квадрат трехзначное число, введённое с клавиатуры, при условии, что в числе содержится цифра 7. Если в числе нет цифры 7, то следует вывести число в исходном виде (через оператор if) Паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)