Задать вопрос
16 декабря, 14:13

Программа вычисления суммы элементов в одномерном массиве

+5
Ответы (1)
  1. 16 декабря, 15:55
    0
    Const

    n = 10;

    var

    x: array[1 ... n] of integer;

    i, s: integer;

    begin

    Randomize;

    Writeln ('Элементы массива') ;

    s : = 0;

    for i : = 1 to n do

    begin

    x[i] : = Random (50) ;

    Write (x[i]:3) ;

    s:=s+x[i]

    end;

    Writeln;

    Writeln ('Сумма элементов массива равна ', s)

    end.

    Тестовое решение:

    Элементы массива

    11 32 9 24 25 19 21 20 40 3

    Сумма элементов массива равна 204
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа вычисления суммы элементов в одномерном массиве ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
1. в одномерном массиве найти значение и номер минимального элемента. 2. в одномерном массиве заменить все элементы кратные 3 на 0.
Ответы (1)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)