Задать вопрос
29 января, 01:51

Переставить последний элемент массива на место первого. При этом первый, второй, ..., последний элементы сдвинуть вправо на 1 позицию

+1
Ответы (1)
  1. 29 января, 02:47
    0
    Program mac;

    uses crt;

    const n=9;

    var c, i:integer; a:array[0 ... n] of integer;

    begin

    writeln ('введите исходный массив') ;

    for i:=0 to n do

    begin

    write ('a[', i,']=') ; readln (a[i]) ;

    end;

    writeln ('вывод исходного массива') ;

    for i:=0 to n do

    write (a[i],' ') ;

    writeln;

    c:=a[n];

    for i:=n-1 downto 0 do

    a[i+1]:=a[i];

    a[0]:=c;

    writeln ('вывод результативного массива') ;

    for i:=0 to n do write (a[i],' ') ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Переставить последний элемент массива на место первого. При этом первый, второй, ..., последний элементы сдвинуть вправо на 1 позицию ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программирование в Pascal) Надо написать программу. 1. N=20 Определить сумму отрицательных элементов массива. 2. Сдвинуть элементы массива на одну позицию вправо, последний элемент переместить на первое место. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)