Задать вопрос
6 марта, 11:20

Программирование в Pascal)

Надо написать программу.

1. N=20 Определить сумму отрицательных элементов массива.

2. Сдвинуть элементы массива на одну позицию вправо, последний элемент переместить на первое место.

3. Все положительные элементы исходного массива записать во второй массив, все отрицательные элементы - в третий массив.

+4
Ответы (1)
  1. 6 марта, 12:19
    0
    1.

    Program A1;

    const n=20;

    var

    i, a:integer;

    O:array[1 ... n] of integer;

    begin

    a:=0;

    for i:=1 to n do begin

    readln (o[i]) ;

    if o[i]<0 then a:=a+o[i];

    end;

    writeln (a) ;

    end.

    2.

    Program A1;

    const n=20;

    var

    i, a:integer;

    O:array[1 ... n] of integer;

    begin

    a:=0;

    for i:=1 to n do readln (o[i]) ;

    a:=o[n];

    for i:=n-1 downto 1 do o[i+1]:=o[i];

    o[1]:=a;

    for i:=1 to n do write (' ', o[i],' ') ;

    end.

    3.

    Program A1;

    const n=20;

    var

    i, a:integer;

    O:array[1 ... n] of integer;

    P:array[1 ... n] of integer;

    M:array[1 ... n] of integer;

    begin

    for i:=1 to n do begin

    readln (o[i]) ;

    if o[i]>0 then p[i]:=o[i];

    if o[i]<0 then m[i]:=o[i];

    end;

    for i:=1 to n do write (' ', o[i],' ') ;

    writeln;

    for i:=1 to n do

    if p[i]0 then

    write (' ', p[i],' ') ;

    writeln;

    for i:=1 to n do

    if m[i]0 then

    write (' ', m[i],' ') ;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программирование в Pascal) Надо написать программу. 1. N=20 Определить сумму отрицательных элементов массива. 2. Сдвинуть элементы массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)