Задать вопрос
20 апреля, 22:37

Дан массив с нулями, вывести порядковые номера элементов массива равные нулю

+3
Ответы (2)
  1. 20 апреля, 22:55
    0
    For i: 1 to n do

    for j:1 to n do

    if mas[i]=0 then

    mas2[j]:=i
  2. 20 апреля, 23:10
    0
    Program a;

    var mas: array of integer;

    i, n:integer;

    begin

    write ('количетво элементов = ') ;

    read (n) ;

    setlength (mas, n) ;

    writeln ('перечислите знач. эл. ') ;

    for i:=0 to n do

    read (mas[i]) ;

    writeln;

    for i:=0 to n do

    if (mas[i]=0) then write (i) ;

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив с нулями, вывести порядковые номера элементов массива равные нулю ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)