Задать вопрос
15 января, 22:40

Дата некоторого дня определяется двумя натуральными числами: m (порядковый номер месяца) и n (число). По заданным m и n определить дату предыдущего дня (принять, что m и n не определяют 1 января).

+3
Ответы (1)
  1. 16 января, 01:10
    0
    Const

    mont: array [1 ... 12] of integer = (31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31) ;

    var

    m, n: integer;

    begin

    write ('m = ') ;

    readln (m) ;

    write ('n = ') ;

    readln (n) ;

    if ((m=1) and (n=1)) or (m<1) or (n12) or (n>mont[m]) then

    writeln ('Неопределенная дата')

    else

    if n=1 then

    begin

    m:=m-1;

    n:=mont[m];

    writeln (n, '-ое число ', m, '-ый месяц')

    end

    else

    begin

    n:=n-1;

    writeln (n, '-ое число ', m, '-ый месяц')

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дата некоторого дня определяется двумя натуральными числами: m (порядковый номер месяца) и n (число). По заданным m и n определить дату ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задание 1. Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. Пример: Введите номер месяца: -2 Введите номер месяца: 11 В этом месяце 30 дней. Вы вводили неверно 1 раз. Задание 2.
Ответы (1)
Напишите программу в паскале. Дано: Дан порядковый номер дня года (отсчет идет с 1-го января). Требуется вывести номер дня недели этого дня, если 1 января - понедельник.
Ответы (1)
На с + + Мальчик-романтик из царства-государства дарит цветы незнакомым дамам-девушкам. Известно, что он дарит цветок каждой пятой даме-девушке, но при этом не дарит цветок, если порядковый номер дамы-девушки кратен 25.
Ответы (1)
Укажите виды циклов А) с заданным условием продолжения работы Б) с полным ветвлением В) с заданным числом повторений Г) с заданным условием окончания работы Д) разветвляющийся
Ответы (1)
Страницы в книгах как правило нумеруются натуральными числами 1,2,3 ... таким образом, что одна сторона первого листа имеет номер 1, обратная сторона того же листа-номер 2. Страницы второго листа пронумерованы числами 3 и 4 соответственно, и т. д.
Ответы (1)