Задать вопрос
14 февраля, 22:21

Составьте программу сортировки по возрастанию значений трех переменных A; B; C

+3
Ответы (1)
  1. 14 февраля, 23:07
    0
    Var a, b, c:integer;

    begin

    readln (a, b, c) ;

    if ((a
    else if ((b
    else if ((c
    if ((a>c) and (c>b)) then writeln (c)

    else if ((b>c) and (b
    else if ((b>a) and (a>c)) then writeln (a) ;

    if ((a>b) and (a>c)) then writeln (a)

    else if ((b>c) and (b>a)) then writeln (b)

    else if ((c>a) and (c>b)) then writeln (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу сортировки по возрастанию значений трех переменных A; B; C ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу сортировки по возрастанию знаачений трех переменных: А Б С 2. Составьте программу вычисления корней квадратонго уравнения по данным знаечениям его коэффициентов
Ответы (1)
1) такое составной оператор? В каких случаях составной оператор используется в операторе ветвления? 2) составьте программу сортировки по возрастанию значений трех переменных: А Б С в системе паскаль
Ответы (1)
Помогите вопросы по информатике. 1. Какой вид сортировки используют для сортировки по нескольким параметрам? 2. Назначение сортировки 3. Какие типы данных можно сортировать.
Ответы (1)
Задания. 1. Найти простейшую формулу от трёх переменных, принимающую значение 0 только на следующих наборах значений переменных: 7) А (0,0,0) = А (0,1,1) = А (1,0,1) = А (1,1,1) 2.
Ответы (1)
Напишите программу, которая сортирует массив и находит количество различных чисел в нем. Используйте алгоритм быстрой сортировки. Пример: Массив: 5 3 4 2 1 6 3 2 4 После сортировки: 1 2 2 3 3 4 4 5 6 Различных чисел: 5
Ответы (1)