Задать вопрос
8 января, 23:07

Программа Паскаль

Пользователь вводит число. Сколько раз из цифр числа можно составить число 23 - столько раз вывести "выведено число 23"

+3
Ответы (1)
  1. 9 января, 01:59
    0
    Program qq;

    var a, count2, count3: integer;

    begin

    writeln ('Введите число') ;

    readln (a) ;

    count2:=0;

    count3:=0;

    while a>0 do

    begin

    if a mod 10 = 2 then

    count2:=count2+1;

    if a mod 10 = 3 then

    count3:=count3+1;

    a:=a div 10;

    end;

    if count2>count3 then

    a:=count3

    else

    if count3>count2 then

    a:=count2

    else

    a:=count2;

    if a0 then

    while a>0 do

    begin

    writeln ('Выведено число 23') ;

    a:=a-1;

    end

    else

    writeln ('Нельзя получить число 23 из цифр введённого числа') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа Паскаль Пользователь вводит число. Сколько раз из цифр числа можно составить число 23 - столько раз вывести "выведено число 23" ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Помогите с программой. Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ставка и на что ставит. пользователь. Ставка идет на конкретное число (от 1 до 36).
Ответы (1)
Программа должна выдавать ошибку если пользователь вводит ноль во втором числе, т. к на 0 делить нельзя и программа отправляет пользователя на повторный ввод, если пользователь умудряется допустить ошибку 3 раза подряд, то программа закрывается.
Ответы (1)