Задать вопрос
11 марта, 23:07

Помогите составить программу. определить является ли введенное вами целое число четным, для четного извлечь квадратный корень, для нечетного возвести в куб.

+1
Ответы (1)
  1. 12 марта, 01:20
    0
    Program z13;

    var a:integer;

    begin

    writeln ('vvedite dannoe cislo=') ;

    readln (a) ;

    if a mod 2=0 then writeln (sqrt (a))

    else writeln (sqr (a) * a) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу. определить является ли введенное вами целое число четным, для четного извлечь квадратный корень, для ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу, проверяющую, что введенное число является четным или нечетным 2. Составьте программу, проверяющую, что введенное число делится без остатка на 3
Ответы (1)
С клавиатуры вводится два трехзначных числа. Возвести первое число в квадрат, а из второго извлечь корень, если хотя бы у одного из чисел, средняя цифра четная. В противном случае из первого извлечь корень, а второе возвести в квадрат.
Ответы (2)
Как составить блок-схему и программу, проверяющую, верно ли утверждение, что введенное вами целое число является четным.
Ответы (1)
Составить программу - калькулятор, которая запрашивает тип математической функции: 1-квадрат, 2-куб, 3 - корень квадратный, 4 - обратная функция, а также аргумент функции x и вычисляет для x соответствующую математическую функцию.
Ответы (1)
Если целое число М, введенное с клавиатуры, делится на целое число Н, введенное с клавиатуры, с остатком равным 2, то вывести на экран целую часть от деления М на Н, в противном случае - сообщение "при делении ... на ... остаток не равен 2"
Ответы (1)