Задать вопрос
4 июля, 10:30

Программа запрашивает у пользователя количество чисел, которое он будет вводить с клавиатуры. После этого пользователь вводит числа, а компьютер находит среднее арифметическое только для положительных чисел

+3
Ответы (1)
  1. 4 июля, 13:24
    0
    Programe pp;

    var a, b, c:integer;

    begin

    writeln ('введите количество чисел') ;

    read (a) ;

    c:=0

    for a=0 do begin

    a:=a-1;

    writeln ('введите число') ;

    read (b) ;

    if b>0 then

    c:=c+b

    else

    Writeln ('положительное число')

    end;

    writeln (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа запрашивает у пользователя количество чисел, которое он будет вводить с клавиатуры. После этого пользователь вводит числа, а ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Программа должна выдавать ошибку если пользователь вводит ноль во втором числе, т. к на 0 делить нельзя и программа отправляет пользователя на повторный ввод, если пользователь умудряется допустить ошибку 3 раза подряд, то программа закрывается.
Ответы (1)
Паскаль программа 1) Программа загадывает случайное целое число из отрезка [1; 10] и просит пользователя его угадать, вводя варианты с клавиатуры, пока пользователь не угадает число, программа будет ему подсказывать, сообщая больше или меньше число
Ответы (1)
Помогите с программой. Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ставка и на что ставит. пользователь. Ставка идет на конкретное число (от 1 до 36).
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)