Задать вопрос
7 января, 04:27

Программа генерирует случайное двузначное число до тех пор, пока не найдется число кратное 5. после чего на экран выводится количество попыток генерации

+5
Ответы (1)
  1. 7 января, 05:38
    0
    Var k, n:integer;

    begin;

    repeat

    k:=k+1;

    n:=random (10,99) ;

    until n mod 5=0;

    writeln ('Число:', n) ;

    writeln ('Попытки:', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа генерирует случайное двузначное число до тех пор, пока не найдется число кратное 5. после чего на экран выводится количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. В языке PHP создайте генератор случайного числа от 1 до 10. Выведите результат выполнения на экран любым способом. 2. Если полученное случайное число четное, выведите на экран слово "четное", иначе выведите на экран слово "нечетное". 3.
Ответы (1)
Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99. Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано".
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Пользователь вводит числа до тех пор, пока она в сумме не дадут число, кратное трем и оканчивающиеся на 3. После чего выводится сообщение о выигрыше в размере среднего арифметического введенных чисел. Решить с помощью динамического массива, в Paskal.
Ответы (1)
Паскаль программа 1) Программа загадывает случайное целое число из отрезка [1; 10] и просит пользователя его угадать, вводя варианты с клавиатуры, пока пользователь не угадает число, программа будет ему подсказывать, сообщая больше или меньше число
Ответы (1)