Задать вопрос
20 декабря, 07:41

Дан ряд четырехзначных натуральных чисел. Из него вычеркивают числа, в которых сумма двух первых цифр равна сумме двух последних. Составить алгоритм и описать его на Паскале, позволяющий по заданному номеру N вывести соответствующее ему число в новой последовательности.

+2
Ответы (1)
  1. 20 декабря, 08:18
    0
    Var n, cnt, i : integer;

    begin

    readln (n) ;

    cnt : = 0;

    i : = 1000;

    while cnt < n do begin

    if i mod 10 + (i div 10) mod 10 (i div 100) mod 10 + i div 1000 then

    cnt : = cnt + 1;

    i : = i + 1;

    end;

    writeln (i - 1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан ряд четырехзначных натуральных чисел. Из него вычеркивают числа, в которых сумма двух первых цифр равна сумме двух последних. Составить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан ряд двузначных натуральных чисел. Из него вычёркивают числа, состоящие из одинаковых цифр. Составить алгоритм и описать его на доступном вам языке программирование (Basic, Паскаль, Си), позволяющий по заданному номеру N вывести соответствующее
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
А. Составьте подпрограмму-функцию, которая по заданному натуральному числу n вычислит сумму его цифр. б. Составьте алгоритм, подсчитывающий количество n-значных натуральных чисел, у каждого из которых сумма цифр равна заданному натуральному числу k.
Ответы (1)