Задать вопрос
29 апреля, 19:30

Дан ряд двузначных натуральных чисел. Из него вычёркивают числа, состоящие из одинаковых цифр. Составить алгоритм и описать его на доступном вам языке программирование (Basic, Паскаль, Си), позволяющий по заданному номеру N вывести соответствующее ему число в новой последовательности.

+3
Ответы (1)
  1. 29 апреля, 21:19
    0
    Var

    i, n, s:byte; / / Здесь мы описываем переменные i - флаг, n - наше число N, s - переменная "деления"

    label l1; / / Здесь мы

    begin

    l1:i:=0; / / Установка метки на начало программы и установка флага на первоначальное значение - НЕТ

    repeat / / проверка N на подлинность

    if i=1 then

    write ('Не верный ввод данных! Повторите ввод:')

    else

    write ('Введите номер N:') ; / / Условие при котором в первый раз выводится предложение где нас просят ввести N, а если же мы её ввели не правильно выводится ошибка и опять нас просят ввести N так продолжается пока мы не введем правильный N

    readln (n) ;

    i:=1; / / Установка флага - ДА

    untill (n>=1) and (n<100) ; / / Ограничения N

    writeln ('Ваше множество:') ; / / Вывод множества;

    for i:=n to 99 do / / из условия следует что числа будут в диапазоне от 1 до 99 т. к они натуральные и двухзначные

    begin

    s:=i mod 11; / / Условие при котором Цифры повторяются т. е. делятся на 11

    if (s0) then write (i,'; ') ; / / Проверка условия выше;

    end;

    writeln;

    write ('Повторить программу? (1-Да, 0-Нет) - ') ; / / Предложение о том сделать ли еще раз программу

    read (i) ;

    if (i=1) then goto L1; / / опять же установка флага и переход к метке L1; если же условие не выполняется, то конец программы

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан ряд двузначных натуральных чисел. Из него вычёркивают числа, состоящие из одинаковых цифр. Составить алгоритм и описать его на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан ряд четырехзначных натуральных чисел. Из него вычеркивают числа, в которых сумма двух первых цифр равна сумме двух последних.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)