Задать вопрос
24 декабря, 18:11

Составить программу. Определить, пересекаются ли линии y=b * x^{2}+c*x+d и y=k*x+m. если пересекаются, найти точки пересечения.

+3
Ответы (1)
  1. 24 декабря, 21:56
    0
    var

    a, b, c, d, k, m: real;

    begin

    readln (b, c, d, k, m) ;

    a : = b;

    b : = c - k;

    c : = d - m;

    d : = sqr (b) - 4 * a * c;

    if (a < 0) then

    writeln ('Нет точек')

    else

    if (d = 0) then

    writeln (' (', (-1 * b + sqrt (d)) / (2 * a), '; ', k * ((-1 * b + sqrt (d)) / (2 * a)) + m, ') ')

    else

    writeln (' (', (-1 * b + sqrt (d)) / (2 * a), '; ', k * ((-1 * b + sqrt (d)) / (2 * a)) + m, '), (', (-1 * b - sqrt (d)) / (2 * a), '; ', k * ((-1 * b - sqrt (d)) / (2 * a)) + m, ') ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу. Определить, пересекаются ли линии y=b * x^{2}+c*x+d и y=k*x+m. если пересекаются, найти точки пересечения. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Составить программу. дана сторона составить программу. дана сторона квадрата а. найти его площадь и периметр. программу составить в программе паскаль ABC
Ответы (1)
Free Pascal 1. Составить программу для вычисления площади прямоугольника по его длинам сторон a и b. 2. Даны два целых числа x и y. Составить программу для нахождения большего из них. 3.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)