Задать вопрос
22 августа, 21:12

Напишите программу формирования и вывода двумерного массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен

сумме двух предыдущих элементов. Два первых элемента задайте с клавиатуры.

+3
Ответы (1)
  1. 22 августа, 22:47
    0
    I, j: integer;

    a: array [1 ... 100, 1 ... 100] of integer;

    begin

    readln (a[1][1], a[1][2]) ;

    for i : = 3 to 30 do

    a[1][i] : = a[1][i - 1] + a[1][i - 2];

    for i : = 2 to 30 do

    for j : = 1 to 30 do

    begin

    if (j > 2) then

    a[i][j] : = a[i][j - 1] + a[i][j - 2]

    else

    if (j = 2) then

    a[i][j] : = a[i][1] + a[i - 1][30]

    else

    a[i][j] : = a[i - 1][30] + a[i - 1][29];

    end;

    for i : = 1 to 30 do

    begin

    for j : = 1 to 30 do

    write (a[i][j],' ')

    writeln;

    end;

    end.

    Вот, сорри если что пишу без компилятора
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу формирования и вывода двумерного массива произвольного размера так, чтобы каждый последующий элемент, начиная с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Дан двухмерный массив m*n случайных целых чисел, которые должны генерироваться в диапазоне [-5, 7], где 1 ≤ т ≤ 9, 1 ≤ n ≤ 10.
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)