Задать вопрос
7 мая, 05:20

Дан массив из N целых чисел. Написать программу, определяющую, максимальный элемент массива и его номер.

+4
Ответы (2)
  1. 7 мая, 07:49
    0
    C++:

    #Include

    using namespace std;

    int main ()

    {

    int N;

    cin >> N;

    int a;

    cin >> a;

    int max = a;

    for (int i = 1; i < N; i++)

    {

    cin >> a;

    if (a > max) max = a;

    }

    cout << max << endl;

    return 0;

    }

    //Тут технически без массива (он не хранится в памяти программы), на самом деле он тут не особо нужен.
  2. 7 мая, 08:25
    0
    Pascal:

    a: array [1 ... 10000] of integer;

    i, n, m: integer;

    begin

    readln (n) ;

    for i : = 1 to n do

    read (a[i]) ;

    m : = 1;

    for i : = 2 to n do

    if (a[i] > a[m])

    then m : = i;

    writeln (a[m],' ', m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из N целых чисел. Написать программу, определяющую, максимальный элемент массива и его номер. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)